Редактор объектов GDL

Редактор объектов GDL имеет все необходимые для редактирования объектов GDL управляющие элементы.

Для подробного ознакомления с командами написания скриптов и редактированием объектов см. Справочное руководство GDL (доступное из меню Справка ARCHICAD).

Открытие редактора объектов GDL

Для открытия редактора объектов GDL выполните одну из следующих операций:

•Для размещенного объекта: выберите объект и затем выполните команду Файл > Библиотеки и объекты > Открыть объект (либо щелкните на одноименной пиктограмме в табло команд Редактирование библиотечных элементов GDL).

//helpcenter.graphisoft.ru/wp-content/uploads/ac21_help/appendix-settings/OpenObject.png

•Для любого файла объекта (и если не выбран размещенный в проекте объект): выполните команду Файл > Библиотеки и объекты > Открыть объект и затем найдите требуемый объект.

Другой способ найти объект – это использовать его подтип: используйте команду Открыть объект по подтипу в табло команд Редактирование библиотечных элементов GDL.

//helpcenter.graphisoft.ru/wp-content/uploads/ac21_help/appendix-settings/EditGDLToolbar001.png

Открывается окно Редактора объектов GDL.

//helpcenter.graphisoft.ru/wp-content/uploads/ac21_help/appendix-settings/GDLMasterWindow.png

Используйте кнопки слева для открытия различных таблиц/списков для редактирования (например, Детали, Параметры, Компоненты) с помощью редактора объектов GDL .

Окна редактирования скриптов (например, Скрипт спецификаций, Скрипт параметров) могут открываться двумя способами.

•Если Вы щелкните на кнопке, редактирование произойдет в Главном окне.

•Щелчок на пиктограмме справа от кнопки с названием скрипта приведет к открытию отдельного окна для ввода/редактирования скрипта.

•Вы можете легко вернуться в Окно Основного скрипта из любого отдельного окна, воспользовавшись контекстным меню Панели Вкладок:

//helpcenter.graphisoft.ru/wp-content/uploads/ac21_help/appendix-settings/TabContext2.png

Объекты  “только для чтения”  из  файла контейнера библиотеки

Для получения доступа к библиотечным элементам в файле контейнера библиотеки следует, прежде всего, извлечь контейнер. В противном случае окно редактора объектов GDL работает в режиме “Только для чтения”.

Для получения дополнительной информации, см. Файл Контейнера Библиотеки.

Темы данного раздела:

Управляющие элементы редактора объектов GDL описываются в следующих разделах.

Изображение Предпросмотра Объекта

Детали

Параметры совместимости (только для разработчиков)

Параметры совместимости (дверь и окно) (только для разработчиков)

Параметры

Миграция

Компоненты

Дескрипторы

Кнопки скриптов

Кнопки окна скриптов GDL

2D-символ

Показ 2D-символа (фрагменты)

Рисунок образца

Проверка 2D- и 3D-видов объекта

Закрытие окна и сохранение изменений

Соответствие 2D- и 3D-описаний

Изображение Предпросмотра Объекта

Окно Изображение Предпросмотра поддерживает пять форматов отображения объекта.

//helpcenter.graphisoft.ru/wp-content/uploads/ac21_help/appendix-settings/ObjectPreview.png

•Нажмите одну из кнопок, расположенных рядом с окном, чтобы выбрать вариант представления объекта: 2D-символ, 2D-вид, Вид Спереди, 3D и Изображение Предпросмотра.

•Выбрав Вид Спереди и 3D, вы можете щелчками мыши в Окне Предпросмотра поворачивать объект с шагом 45 градусов.

Детали

Подтип объекта. Показывается подтип открытого объекта.

•Вы можете изменить подтип объекта, нажав кнопку Выбрать подтип, по которому отрывается диалоговое окно Иерархия подтипов. Изменение подтипа объекта приводит к модификации его поведения и добавлению специфических для подтипа параметров и функциональности. Например, Вы можете изменить обычный объект на источник света, присвоив ему подтип Источник света.

Для получения дополнительной информации, см. Диалоговое окно Иерархия подтипов (Главное окно GDL).

Использовать как подтип. Если Вы отметите этот маркер, объект будет сохранен как шаблон с включением в список имеющихся подтипов. Новый шаблон появится в диалоге Иерархия подтипов и все вновь создаваемые объекты этого типа будут унаследовать его параметры.

Размещаемый маркер является выбранным по умолчанию. При снятии отметки с него объект будет вести себя как макрос. Если этот маркер не отмечен, то это означает, что данный объект:

•не появится ни в одном диалоговом окне установки параметров инструмента;

•нельзя будет непосредственно разместить в проекте;

•нельзя будет включить в архивный файл проекта;

•но Вы можете ссылаться на его скрипт из другого объекта.

Поля с информацией об объекте

Следующие несколько элементов управления играют роль, если вы хотите загрузить библиотечный элемент на BIM Components или сделать его коммерческим. Кроме того, любой введенный в эти поля текст принимается во внимание при поиске в окне параметров библиотечного элемента.

См. Поиск библиотечного элемента.

Введите или отредактируйте следующую информацию.

Автор. (Если это поле останется не заполнено, то в качестве автора загруженного объекта будет использоваться имя, указанное вами при регистрации на BIM Components.)

Лицензия. Введите лицензию (авторские права). Предоставляется три варианта:

Общественное достояние. Щелкните на кнопке Информация для перехода на веб-страницу с информацией об этой лицензии:
http://creativecommons.org/publicdomain/zero/1.0/

Атрибуция – Без производных произведений. Щелкните на кнопке Информация для перехода на веб-страницу с информацией об этой лицензии:
http://creativecommons.org/licenses/by-nd/3.0/

Коммерческая. Используйте этот вариант лицензии, если Вы предполагаете продавать объект в Интернет. Объект с Коммерческим типом лицензии нельзя загрузить на BIM Components. Щелкните на кнопке Информация для перехода на веб-страницу с информацией об этой лицензии.

Пароль (доступен, если выбрана лицензия Атрибуция – Без производных произведений или Коммерческая). Установить пароль. Щелкните на этой кнопке, чтобы определить факультативный пароль. Такой объект может свободно просматриваться и закачиваться, но нельзя его открыть для редактирования или копирования скрипта без знания пароля.

Описание. Введите факультативное описание объекта. Этот текст отображается при нажатии кнопки Инфо в диалоге Параметров Объекта, а также – на BIM Components, если объект загружается на сайт. Кроме того, описание используется при поиске библиотечных элементов в диалоге Параметры объекта.

Параметры совместимости (только для разработчиков)

Диалоговое окно Параметры совместимости, доступное со страницы Детали редактора объектов  GDL, имеет отношение к размерам (экземпляра) элемента.

Примечание: Двери и окна имеют различные управляющие элементы в диалоговом окне Детали: см. следующий раздел.

//helpcenter.graphisoft.ru/wp-content/uploads/ac21_help/appendix-settings/CompatibilityOptions.png

Размеры экземпляра объекта. Эти альтернативные кнопки устанавливают, каким образом размещенные объекты (экземпляры объектов) сохраняют значения своих параметров.

Сохранять пропорции текущих/стандартных размеров A/B. Указывает, что размещаемые объекты будут пропорционально изменяться согласно стандартным размерам A и/или B.

Сохранять фиксированные размеры. Объекты, уже размещенные в проекте, не будут изменяться при последующих изменениях их стандартных размеров А/В.

Статус совместимости:

•Объект миграции (отсутствует новая совместимая версия этого объекта),

•Всегда показывать в параметрах объекта.

Эти управляющие элементы используются только разработчиками, работающими с объектами  ARCHICAD. Эти маркеры обозначают объекты, которые не будут автоматически получать их новые аналоги в новых версиях библиотеки.

Узловые точки вокруг символа. Если Вы отметите этот маркер, то с 2D-символом библиотечного элемента связываются пять узловых точек. Они будут независимыми от узловых точек, определенных в GDL-скрипте элемента. Эти узловые точки располагаются по углам и в середине прямоугольника, который окаймляет символ (воображаемый прямоугольник, ограничивающий символ). Если Вы отметили маркер Узловые точки вокруг символа, то по умолчанию текущей узловой точкой, которая используется для размещения библиотечного элемента на плане этажа, является левая снизу. (Это Вы можете заметить по маленькому прямоугольнику вокруг нее на изображении символа Здесь же Вы можете изменить текущую узловую точку).

Если Вы не хотите, чтобы узловой точкой по умолчанию считалась левая снизу, то не отмечайте упомянутый выше маркер и опишите требуемые узловые точки в GDL-скрипте. В данном случае узловой точкой по умолчанию будет принята первая из описанных.

Если маркер не отмечен и GDL-скрипт не содержит узловых точек, ARCHICAD разместит единственную узловую точку в начале координат библиотечного элемента и будет использовать ее в качестве текущей по умолчанию.

По размеру 2D-символа. Отметьте этот маркер, чтобы передать размеры по осям А и В текущего 2D-символа в поля стандартных значений размеров А и В главного окна.

Параметры совместимости (дверь и окно) (только для разработчиков)

//helpcenter.graphisoft.ru/wp-content/uploads/ac21_help/appendix-settings/CompatibilityOptionsWindow.png

Производные размеры. Используйте поля редактирования в этом разделе диалогового окна для определения геометрических взаимосвязей между проемом в стене и дверью или окном. Используйте для этого числовые выражения GDL.

Номинальная толщина коробки. Здесь указывается номинальная толщина коробки.

Вставка парапетной стены. Здесь определяется вставка парапетной стены.

Зазор в проеме. Определяется увеличенный размер проема относительно номинальных размеров (A и B) для Y +, Y- (вверху и внизу) и X +, X- (справа и слева).

Ориентация. Используйте эти управляющие элементы для определения способа представления ориентации проема (например, R для правой ориентации и L – для левой).

По умолчанию. Нажмите эту кнопку, чтобы выбрать ориентацию проема окна/двери в качестве стандартной установки по умолчанию.

Обратная. Нажмите эту кнопку, чтобы ориентация проема окна/двери была обратной относительно стандартной установки по умолчанию.

Специальный. Нажмите эту кнопку, чтобы настроить воспроизведение ориентации проема окна/двери путем ввода специальных выражений в окошки редактирования, расположенные рядом.

Статус совместимости (только для разработчиков)

•Объект миграции (отсутствует новая совместимая версия этого объекта),

•Всегда показывать в параметрах объекта.

Эти управляющие элементы используются только разработчиками, работающими с объектами  ARCHICAD. Эти маркеры обозначают объекты, которые не будут автоматически получать их новые аналоги в новых версиях библиотеки.

Отключить 3D-контуры. Отметьте этот маркер, чтобы спрятать 3D-контуры выбранного объекта окна/двери (при просмотре в каркасном режиме или в режиме с удалением невидимых линий).

Параметры

Чтобы представить в редактируемой области список параметров библиотечного элемента, нажмите эту кнопку.

Поиск параметров. Введите текстовую строку в поле поиска, чтобы найти ее в столбцах Переменная, Имя, Значение. Курсор располагается на первой найденной строке. Используйте кнопки Найти следующий/Найти предыдущий для перехода на другие экземпляры поисковой строки.

//helpcenter.graphisoft.ru/wp-content/uploads/ac21_help/appendix-settings/SearchObjectParameters.png

Присваивания значения переменным в списке параметров, Вы определяете реквизиты конкретного объекта GDL. Значения, присваиваемые параметрам, становятся значениями по умолчанию, которые появляются в диалогах установки параметров инструмента для данного объекта. Различные скрипты объекта имеют доступ к этим локально определенным параметрам.

Параметры, представленные синим цветом, являются обязательными параметрами (например, размеры А и В), принадлежащими подтипу объекта.

Факультативные параметры доступны для использования в GDL-описании объекта. Присваиваемые им значения становятся значениями по умолчанию в диалоговых окнах параметрической установки соответствующих инструментов.

Факультативные параметры обычно используются для указания, например, количества оконных створок или  дверных полотен, одинаковых покрытий и т.п.

Новый параметр создается нажатие кнопки Новый в верхней части главного окна. Чтобы удалить параметр, следует его выбрать и нажать кнопку Удалить.

Каждый параметр в списке можно редактировать самостоятельно. Строка параметра состоит из пиктограммы (обязательная), указывающей его тип, буквенного обозначения параметра или строки обозначения переменной, описательного текста (факультативное, но рекомендуемое), числового значения по умолчанию.

Выберите строку, которую хотите отредактировать. У обязательного параметра нельзя менять имя его переменной и тип. У факультативного параметра можно менять любые его характеристики.

Пиктограммы типа указывают, как параметр интерпретируется ARCHICAD. Щелкнув мышкой на пиктограмме, Вы открываете небольшое диалоговое окно выбора типа параметра, в котором можно выбрать пиктограмму другого типа.

//helpcenter.graphisoft.ru/wp-content/uploads/ac21_help/appendix-settings/Integer.png

Типы параметров являются одинаковыми для обязательных и факультативных параметров. Далее приводится их описание.

•Длина

//helpcenter.graphisoft.ru/wp-content/uploads/ac21_help/appendix-settings/Length.png

Определяет физические размеры объекта GDL. Они всегда пересчитываются при выборе другой единицы измерения. Должна быть положительным числом.

•Наклон.

//helpcenter.graphisoft.ru/wp-content/uploads/ac21_help/appendix-settings/Angle.png

Определяет угловые размеры в градусах с десятичными знаками. Используются в таких операциях GDL, как поворот системы координат, определение дуг

•Действительное число

//helpcenter.graphisoft.ru/wp-content/uploads/ac21_help/appendix-settings/RealNumber.png

Определяет десятичные числа. Используются в GDL-скриптах, например, в качестве коэффициента увеличения/уменьшения. Нельзя использовать в качестве размерных чисел.

•Целое число

//helpcenter.graphisoft.ru/wp-content/uploads/ac21_help/appendix-settings/Integerpici.png

Определяет целые числа. Используется в GDL-скриптах, например, для указания количества идентичных компонент или количества выполняемых циклов. Нельзя использовать в качестве размерных чисел.

•Истинностное значение

//helpcenter.graphisoft.ru/wp-content/uploads/ac21_help/appendix-settings/Booleanpici.png

Определяет значение параметра логического типа. Истинностное значение равно 0 или 1. Оно может использоваться, например, для активизации или завершения какого-нибудь действия или элемента в библиотеке. Это значение может быть введено непосредственно в окошко или с помощью отметки (снятия отметки) маркера.

•Текст

//helpcenter.graphisoft.ru/wp-content/uploads/ac21_help/appendix-settings/abc.png

Определяет символьную строку, содержащую не более 255 символов. Может использоваться, например, для определения изменений в объектах GDL или для ввода обычных слов вместо числовых значений в окошках параметров.

•Поверхность.

//helpcenter.graphisoft.ru/wp-content/uploads/ac21_help/appendix-settings/Materialpici.png

определяет покрытие в качестве параметра GDL.

Тип линии.

//helpcenter.graphisoft.ru/wp-content/uploads/ac21_help/appendix-settings/Linepici.png

Определяет тип линии в качестве параметра GDL.

•Образец штриховки

//helpcenter.graphisoft.ru/wp-content/uploads/ac21_help/appendix-settings/Fillpici.png

Определяет образец штриховки в качестве параметра GDL.

•Цвет пера

//helpcenter.graphisoft.ru/wp-content/uploads/ac21_help/appendix-settings/Penpici.png

Определяет цвет пера в качестве параметра GDL.

Примечание: При выборе параметра, относящегося к Покрытию, Типу линии, Образцу штриховки или Цвету пера, справа в строке параметра появляется стрелка, позволяющая открыть всплывающее меню с допустимыми значениями параметра. Эти меню содержат все допустимые реквизиты ARCHICAD соответствующего типа.

//helpcenter.graphisoft.ru/wp-content/uploads/ac21_help/appendix-settings/107_12.png

Примечание: В зависимости от способа написания GDL-скриптов, параметры могут оказывать влияние на 2D- и 3D-представления библиотечного элемента.

Типы параметров включают два дополнительных типа: разделитель и  заголовок.

//helpcenter.graphisoft.ru/wp-content/uploads/ac21_help/appendix-settings/Separatorpici.png     //helpcenter.graphisoft.ru/wp-content/uploads/ac21_help/appendix-settings/Titlepici.png

Это виртуальные параметры в том смысле, что они не используются по существу, а задаются для придания списку параметров большей наглядности.

Для дальнейшей структуризации и форматирования списка параметров используйте следующие три пиктограммы , которые появляются только при выборе строки параметра.

//helpcenter.graphisoft.ru/wp-content/uploads/ac21_help/appendix-settings/lib_main_para_form.png

•Нажмите кнопку Спрятать параметр, чтобы он не приводился в списке параметров диалогового окна установки параметров объектов.

•Вторая кнопка , Подчиненный параметр, позволяет создавать иерархию среди параметров. Когда имеется иерархия параметров, то подчиненные параметры, то есть параметры нижнего уровня, появляются в виде подсписков в диалоге установки параметров объектов. Подсписок может быть открыт и закрыт с помощью небольшой треугольной кнопки, расположенной рядом с именем параметра верхнего уровня. Параметр верхнего уровня может быть любого типа; однако параметр заголовка не может быть подчиненным.

•Нажатие третьей кнопки, Представить жирным шрифтом, приводит к представлению параметра жирным шрифтом.

•Четвертая пиктограмма Уникальный (если она активна) означает, что текущий параметр НЕ будет передаваться, когда Вы передаете параметры этого объекта другому объекту.

См. Передача параметров между объектами.

Вы можете ограничить возможные значения параметра, определив массив или матрицу.

При выборе строки с параметром появляется новая пиктограмма  рядом с пиктограммой типа.

//helpcenter.graphisoft.ru/wp-content/uploads/ac21_help/appendix-settings/lib_main_para_array.png

Она позволяет переключаться с указания единственного значения на массив значений и наоборот. При нажатии этой кнопки открывается диалоговое окно Значения массива.

Примечание: После определения значений массива диалоговое окно Значения массива может быть открыто только при нажатии кнопки Установить в верхней части главного окна.

Для вставки или удаления строки или столбца выберите кнопку с изображением номера
строки или столбца и затем нажмите кнопку Вставить или Удалить. Отредактируйте поля массива щелчком в поле с последующим вводом значения в поле справа. Если тип переменной допускает это, то выбор значения производится из соответствующего всплывающего меню.

Для вставки или удаления строки или столбца выберите кнопку с изображением номера  строки или столбца и затем нажмите кнопку Вставить или Удалить.

Миграция

Нажмите кнопку Миграция, чтобы открыть таблицу, в которой следует определить объекты более старой версии, которые должны быть мигрированы в текущий открытый объект более новой версии.

•Введите основной GUID старого объекта, который может быть мигрирован в данный открытый объект.

•Введите номер версии старого объекта (обычно это версия предыдущего ARCHICAD): когда проект сохраняется в предыдущую версию (и если отмечен маркер Обратная конвертация библиотечных элементов в диалоге Параметры сохранения команды Сохранить как), этот новый объект будет мигрирован в старый объект в таблице миграции, которая приписана соответствующему номеру версии. Скрипт обратной миграции будет просматривать все такие строки до тех пор, пока не найдет первую успешную.

Примечание: Если Вы введете 0 в качестве номера версии, обратная миграция пропустит этот объект.

Компоненты

Чтобы представить в редактируемой области список компонент библиотечного элемента, нажмите эту кнопку. Компоненты определяют состав объекта с точки зрения его использования в сметах.

//helpcenter.graphisoft.ru/wp-content/uploads/ac21_help/appendix-settings/GDLComponent.png

Новый. Нажмите кнопку Новый для создания компоненты.

Набор БД. Выберите базу данных из этого всплывающего меню.

Ключ. Выберите один из ключей из этого всплывающего меню.

Примечание: Это всплывающее меню оказывается доступным только в том случае, когда загруженная библиотека содержит описание ключей.

Код. Здесь задается или изменяется код компоненты.

Количество. Здесь определяется или изменяется количество компоненты.

Единицы: Выберите из этого всплывающего меню одну из предварительно определенных единиц измерения.

Примечание: Это всплывающее меню оказывается доступным только в том случае, когда загруженная библиотека содержит описание единиц измерения.

Соотношение. Выберите одно из ранее определенных GDL-выражений из этого всплывающего меню или введите любое GDL-выражение в окошко редактирования выше, выбрав предварительно в меню вариант Специальный.

Для ознакомления с деталями редактирования компонент см. Руководство по проведению расчетов ARCHICAD.

Дескрипторы

Чтобы представить в редактируемой области список дескрипторов библиотечного элемента, нажмите эту кнопку. Дескрипторы определяют состав объекта с точки зрения его использования в сметах.

//helpcenter.graphisoft.ru/wp-content/uploads/ac21_help/appendix-settings/Descriptor.png

Новый. Нажмите кнопку Новый для создания дескриптора.

Связать с БД. Нажмите эту кнопку, чтобы связать компоненту или дескриптор с внешней базой данных, расположенной в выбранных базах данных загруженной библиотеки. Компонента или дескриптор не могут редактироваться до тех пор, пока они связаны с выбранной базой данных. Для их изменения нажмите кнопку Удалить связь с БД, чтобы разорвать эту связь.

Изменить связь. Щелкните здесь, чтобы переопределить существующую связь на другую внешнюю базу данных.

Текст Чтобы открыть диалоговое окно представления полного текста дескриптора, нажмите эту кнопку.

Краткий текст. Введите здесь короткий текст нового дескриптора.

Для получения дополнительной информации о редактировании дескрипторов см. Руководство по проведению расчетов ARCHICAD.

Кнопки скриптов

Эти кнопки позволяют приступить к программированию объекта GDL. Если Вы нажмете саму кнопку, то программирование будет происходить в главном окне, а если нажмете пиктограмму окна рядом с именем кнопки, то откроется самостоятельное окно для ввода и редактирования скрипта.

//helpcenter.graphisoft.ru/wp-content/uploads/ac21_help/appendix-settings/ScriptWindows.png

Основной скрипт – это тот, который выполняется всякий раз, когда происходит обращение к любому другому скрипту библиотечного элемента. Его основное назначение заключается в том, чтобы расположить в нем глобально определяемые переменные или операции или произвести в нем доступ к внешним данным перед выполнением любого другого скрипта.

•С помощью 2D-скрипта Вы можете определить параметрический 2D-символ с помощью двумерных преобразований и команд GDL, предназначенных для создания плоских фигур. Этот скрипт используется для создания полного 2D-вида объекта.

3D-скрипт предназначен для создания и/или редактирования GDL 3D-скриптов библиотечных элементов. Этот скрипт используется для создания 3D-вида объекта.

•С помощью скрипта спецификаций Вы можете связывать с определением библиотечного элемента ряд специальных технических данных с использованием переменных библиотечного элемента, а также соответствующих команд и выражений языка GDL. Характеристики компонент (вес, цена, объем и т.п.) подсчитываются согласно описанным в скрипте спецификаций выражениям и используются при составлении сметы. Для использования специального скрипта спецификаций в качестве скрипта по умолчанию в диалоге установки параметров элемента, нажмите кнопку Установить по умолчанию в верхней части экрана.

Примечание: Если библиотечный элемент имеет скрипт спецификаций, смета будет составляться с учетом именно его. Это означает, что при наличии скрипта спецификаций при составлении сметы будут игнорироваться приписанные элементу компоненты и дескрипторы.

•С помощью скрипта параметров можно определить множество допустимых значений параметра. Например, можно ограничить набор покрытий, доступных для столешницы, только деревянными, или определить множество допустимых типов филенок для двери по их именам.

Скрипт интерфейса позволяет определить специальный интерфейс пользователя для объекта GDL, включая и графическое представление дополнительных параметров. Если скрипт интерфейса существует, то диалоговое окно установки параметров этого библиотечного элемента будет содержать панель Специальные параметры. Для использования специального скрипта интерфейса в качестве скрипта по умолчанию в диалоге установки параметров элемента, нажмите кнопку Установить по умолчанию в верхней части экрана.

Скрипты /прямой и обратной миграции. Щелкните на кнопке Прямая миграция или Обратная миграция, чтобы определить, как мигрировать параметры более старого экземпляра вперед – то есть в текущий открытый элемент (или назад – в более старую версию).

Кнопки окна скриптов GDL

В верхней части окон скриптов располагаются пиктографические кнопки доступа к наиболее часто используемым командам редактирования.

//helpcenter.graphisoft.ru/wp-content/uploads/ac21_help/appendix-settings/CheckScript.png

•Щелчок на первой кнопке приводит к тому, что выбранные строки преобразуются в комментарии, то есть в строки, которые не выполняются в скрипте. Строки комментариев отмечаются восклицательным знаком в начале.

Примечание: Вы можете выбрать более, чем одну строку.

•Вторая кнопка имеет прямо противоположный эффект: щелчок на ней приводит к преобразованию выбранных строк комментариев в строки исполняемого кода.

•Щелчок на третьей или четвертой кнопке приводит к увеличению или уменьшению отступа для всех выбранных строк.

•Последняя кнопка инициирует проверку GDL-скрипта активного окна.

Примечание: При работе в окне скрипта все эти функции также доступны в виде команд меню Редактор вместе с другими специальными командами работы в окнах скриптов.

Примечание: Окна редактирования скриптов спецификаций, интерфейса и параметров также включают кнопку Просмотр для предварительного просмотра специального скрипта.

2D-символ

Щелчок на кнопке 2D-символ в главном окне приводит к открытию окна редактирования 2D-символа элемента.

Объект GDL представляется на плане этажа своим 2D-символом. Вы можете редактировать существующий символ или создать новый с помощью стандартных 2D-инструментов ARCHICAD: Указатель, Бегущая рамка, Текст, Штриховка, Линия, Дуга/окружность, Сплайн-кривая и Узловая точка. Вы также можете вставлять в это окно элементы из 3D-окна.

Результирующее обозначение, которое используется на плане этажа, формируется на основе символа, представленного в этом окне, а также 2D-скрипта, если он имеется.

Показ 2D-символа (фрагменты)

Чтобы увидеть фрагменты 2D-символа, нажмите кнопку 2D-символ и затем выполните команду Параметры > Реквизиты элементов > Параметры слоев. В открывшемся окне приводится список фрагментов 2D-символа: С их помощью указываются те фрагменты элемента, которые представляются в 2D-символе.

Чтобы переключить видимость слоев 2D-символа объекта, откройте окно 2D-символа и нажмите комбинацию клавишей Ctrl+L (клавишная команда открытия окна Параметры слоев). Открывается специальное окно Параметры слоев, которое имеет отношение только к текущему окну (окну 2D-символа).

Нажмите на кнопку любого фрагмента, чтобы показать/спрятать его, или используйте для этого кнопки Показать все/Спрятать все.

Примечание: Спрятанный фрагмент не доступен для размещения в нем новых чертежных примитивов. Если в диалоговом окне установки параметров выбранного Вами инструмента указывается такой фрагмент, то выдается сообщение, которое предлагает Вам либо показать выбранный фрагмент, либо выбрать другой.

Фрагменты позволяют самостоятельно обращаться к отдельным частям символа. Вы можете нарисовать в 2D-окне какую-либо плоскую фигуру под определенным номером фрагмента и затем ссылаться на нее по этому номеру в 2D-скрипте. При этом в процессе формирования результирующего изображения символа можно использовать операции перемещения и/или поворота фрагментов.

Для указания фрагмента, к которому должен относиться вычерчиваемый Вами примитив, откройте диалоговое окно нужного инструмента и выберите требуемый номер во всплывающем меню слоев.

 Рисунок образца

Открытие этого окна позволяет добавить к библиотечному элементу графическую информацию. Эта графика никак не влияет на поведение объекта или его внешний вид. Рисунок образца выводится в просмотровых окошках диалоговых окон установки параметров объектов, а также вместе с именами библиотечных объектов при их просмотре в диалогах открытия файлов.

Для получения рисунка образца нового объекта поступите следующим образом:

1.Разместите объект в проекте.

2.Выберите объект и откройте 3D-окно, чтобы посмотреть на него.

3.Активируйте команду меню Вид > Параметры 3D-вида > Параметры 3D-проекции. Выберите тип проекции и угол обзора Объекта. Нажмите кнопку ОК.

4.Откройте диалог Настройки Размеров Окна (при помощи контекстного меню вкладки 3D-окна или контекстного меню 3D-окна). Задайте одинаковые значения размеров окна, чтобы получить квадратное окно.

5.Выполните команду Документ > Визуализация > Параметры Визуализации. В области результирующего изображения установите размер в пикселах, чтобы можно было без искажений вставить изображение в окно образца. Выберите также нейтральный фон изображения объекта (например, белый цвет для земли и неба).

6.При все еще выбранном объекте выполните команду Документ > Визуализация > Начать Визуализацию. Создается рисунок модели (макетное изображение).

7.Выполните последовательно команды Редактор > Выбрать все и Редактор > Копировать.

8.Перейдите на план этажа. При выбранном объекте выполните команду Файл > Библиотеки и объекты > Открыть объект. Откроется главное окно выбранного объекта.

9.Откройте окно рисунка образца и выполните команду Редактор > Вставить.

10.Сохраните этот объект GDL.

Из буфера обмена Вы можете вставить другие данные, например, фотографию реального объекта.

Проверка 2D- и 3D-видов объекта

В нижней части располагаются кнопки, которые позволяют открыть соответствующий вид объекта GDL в отдельном окне:

//helpcenter.graphisoft.ru/wp-content/uploads/ac21_help/appendix-settings/2D3DView.png

2D-вид

В данном окне Вы можете посмотреть, как будет выглядеть символ на плане этажа.

Если элемент имеет 2D-скрипт, то окно 2D-вида будет представлено согласно этому скрипту, даже если окно 2D-символа что-то содержит. Тем не менее, 2D-скрипт может ссылаться к фрагментам 2D-символа.

Для выхода из режима редактирования (определения) 2D-символа закройте его окно или перейдите в другое окно с помощью соответствующей кнопки главного окна библиотечного элемента или команды меню Окно.

3D-вид

В этом окне воспроизводится трехмерное изображение объекта GDL, построенное согласно его GDL 3D-скрипта. Точка наблюдения и другие характеристики контролируются с помощью диалогового окна команды Вид > Параметры 3D-вида > Стили 3D-или панели 3D-навигации.

Закрытие окна и сохранение изменений

При закрытии главного окна появляется сообщение, предлагающее сохранить произведенные изменения. Все составляющие объекта будут сохранены в одном файле.

Сохранить объект также можно командами Сохранить и Сохранить как, находясь в любом окне библиотечного элемента. (Из 3D-окна сохранить его изображение можно по команде Сохранить как.) После сохранения можно выполнить команду Вид > Обновить > Построить заново для плана этажа или 3D-окна, чтобы посмотреть на обновленный объект GDL.

Если Вы закрываете главное окно объекта GDL (библиотечного элемента), будут также закрыты все другие окна этого объекта. Если были сделаны изменения в объекте, то будет выдано сообщение, предлагающее сохранить их.

Соответствие 2D- и 3D-описаний

2D-символ и 3D-описание элемента автоматически связываются друг с другом в объекте GDL. В ARCHICAD нет механизмов проверки их несогласованности. Наиболее существенные несоответствия между 2D-символом и 3D-фигурой возникают в том случае, если они определяют различное расположение и ориентацию относительно начала координат.

Во избежание этого предлагаем поступить следующим образом.

1.Сделайте текущим окно 3D-вида объекта GDL.

2.В диалоговом окне команды Вид > Параметры 3D-вида > Параметры 3D-проекции > Параллельная проекция выберите Вид сверху и установите угол 270°.

3.Выполните последовательно команды Редактор > Выбрать все и Редактор > Копировать. Войдите в окно 2D-символа и выполните команду Редактор > Вставить. Это приведет к размещению вида сверху (каркасная визуализация или с удалением невидимых линий) библиотечного элемента в окне 2D-символа. Полученная проекция трехмерного изображения должна совпасть по размерам и расположению с 2D-символом.

4.Убедившись в этом, выберите команду Отменить меню Редактор. Это приведет к удалению из окна 2D-символа линий трехмерного изображения.

Этим же способом Вы можете создавать 2D-символы. Вам только придется дополнительно определить узловые точки, типы линий и т.п. Процедура годится также для окон и дверей с учетом следующих особенностей:

•вместо вида сверху выберите вид сбоку (угол должен остаться 270°);

•в окне 2D-символа будет размещено зеркальное отражение. Выберите размещенные линии и произведите их зеркальное отражение относительно линии привязки стены.

Примечание: При размещении каркасного изображения излишние линии будут удалены. Изображение С Удалением Невидимых Линий дает точный вид, но невидимые линии будут скрыты.

Проблемы соответствия между 2D-символом и 3D-моделью библиотечного элемента могут быть решены написанием в GDL параметрического 2D-скрипта.

Обсуждение закрыто.